第五届河南省赛 zzulioj 1478: Metric Matrice (模拟)

133 篇文章 0 订阅
59 篇文章 0 订阅

1478: Metric Matrice

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 70   Solved: 35

Submit Status Web Board

Description

nt j, determine if the distance matrix is "a  metric" or not.

 

A distance matrix a[i][j] is a metric if and only if

    1.  a[i][i] = 0

    2. a[i][j]> 0  if i != j

    3.  a[i][j] = a[j][i]

    4.  a[i][j] + a[j][k] >= a[i][k]   i ¹ j ¹ k

Input

The first line of input gives a single integer, 1 ≤ N ≤ 5,  the number of test cases. Then follow, for each test case,

* Line 1: One integer, N, the rows and number of columns, 2 <= N <= 30

* Line 2..N+1: N lines, each with N space-separated integers 

(-32000 <=each integer <= 32000). 

Output

Output for each test case , a single line with a single digit, which is the lowest digit of the possible facts on this list:

    * 0: The matrix is a metric

    * 1: The matrix is not a metric, it violates rule 1 above

    * 2: The matrix is not a metric, it violates rule 2 above

    * 3: The matrix is not a metric, it violates rule 3 above

    * 4: The matrix is not a metric, it violates rule 4 above

Sample Input

2
4
0 1 2 3
1 0 1 2
2 1 0 1
3 2 1 0
2
0 3
2 0

Sample Output

0
3
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[31][31];
int main()
{
	int t,n,i,j,k;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				scanf("%d",&a[i][j]);
			}
		}
		int flag=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				if(i==j&&a[i][j]!=0)
				{
					flag=1;
					break;
				}
				else if(i!=j&&a[i][j]<=0)
				{
					flag=2;
					break;
				}
				else if(a[i][j]!=a[j][i])
				{
					flag=3;
					break;
				}
				else
				{
					for(k=0;k<n&&k!=i&&k!=j&&i!=j;k++)
					{
						if(a[i][j]+a[j][k]<a[i][k])
						{
							flag=4;
							break;
						}
					}
					if(flag)
						break;
				}
			}
			if(flag)
				break;
		}
		printf("%d\n",flag);
	}
	return 0;
}

Source

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值