poj-2395 Out of Hay

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.
Input
* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
Output
* Line 1: A single integer that is the length of the longest road required to be traversed.
Sample Input
3 3
1 2 23
2 3 1000
1 3 43
Sample Output
43
Hint
OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.


题意:农场的草被牛吃完了,Bessie要从其他农场运来新的草,但是要准备足够的水路上用。

因为在到了一个农场的时候,她可以得到更多的水,所以她只关心最长的一段路的长度。有些农场可能与不同长度的公路相连,而每一条路都是双向的。并且,所有的农场都已一种或另一种方式连接到农场1,计划一条路线,减少她带的水的量。

其实就是计算出最小生成树中最大的权。

用二维数组mp记录路径和权值,但是输入的时候一定要注意,同一条路径,只需要存储权值最小的那个值就好,因为这一点WA了十遍。

例如:1->2   1

           1->2   3

如果不在输入时比较1->2这条路径的权值,mp[1][2]的当前值就是3。

scanf("%d%d%d",&a&b,&c);

if(c<mp[a][b])

   mp[a][b]=mp[b][a]=c;

用prime算法求最小生成树,然后在求最小生成树的过程中,每求出一条路径的最优解时,就和目前的最大权值max比较一次,更新max的值,求出最小生成树中最大的权值。


#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f

int n,m;
int mp[3000][3000],dis[3000];

void prim()
{
    int v,minn,book[3000]= {0};
    int maxx=-1;

    for(int i=1; i<=n; i++)
        dis[i]=mp[1][i];
    dis[1]=0;
    book[1]=1;

    int t=1;
    while(t<n)
    {
        minn=INF;
        for(int i=1; i<=n; i++)
        {
            if(!book[i] && dis[i] < minn)
            {
                minn=dis[i];
                v=i;
            }
        }
        book[v]=1;
        t++;
        if(maxx<minn)
            maxx=minn;  //更新最小生成树中的最大权值
        for(int i=1; i<=n; i++)
            if(!book[i] && dis[i]>mp[v][i])
                dis[i]=mp[v][i];
    }
    printf("%d\n",maxx);
}

int main()
{
    int a,b,c;
    scanf("%d%d",&n,&m);
    for(int i=1; i<=n; i++)
        for(int j=1; j<=n; j++)
        {
            if(i==j)
                mp[i][j]=0;
            else
                mp[i][j]=INF;
        }
    for(int i=0; i<m; i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        if(c<mp[a][b])
            mp[a][b]=mp[b][a]=c;
    }
    prim();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值