694 - The Collatz Sequence

An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1:
Choose an arbitrary positive integer A as the first item in the sequence.
Step 2:
If A = 1 then stop.
Step 3:
If A is even, then replace A by A / 2 and go to step 2.
Step 4:
If A is odd, then replace A by 3 * A + 1 and go to step 2.

It has been shown that this algorithm will always stop (in step 2) for initial values of A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

Input 

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value of A (for step 1) and the second giving L, the limiting value for terms in the sequence. Neither of these, A or L, is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of A is always less than L. A line that contains two negative integers follows the last case.

Output 

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for A, the limiting value L, and the number of terms computed.

以下这个由Lothar Collat​​z定义的演算法可以产生一连串数列:

Step1:
任选一个正整数A作为这个数列的第一项。
Step2:
如果A=1则停止。
Step3:
如果A为偶数,则A=A/2然后重新回到Step2。
Step4:
如果A为奇数,则A=3*A+1然后重新回到Step2。
这个演算法已经被证明当首项小于等于109时这个数列最终都会在Step2停止,但是有些A值在这个数列中会超出许多电脑的整数上限。在这个问题中我们想​​要计算这个数列的长度,而数列的终止有两种情况:1.最终会在Step2停止或是2.某一项会在Step4超出一个特定的上限。

Input

输入包含许多组待测资料,每一列代表一组待测资料,每组待测资料包含两个正整数,第一个数为首项A,第二个数为这个数列的上限L,无论A或L都不会大于2,147,483,647(32位元有号整数的最大值),且首项A总是小于上限L。当输入为两个负数时代表输入结束。

Output

对每组待测资料必须输出它为第几组(从1开始),一个冒号,首项A的值,上限L的值,以及此一数列的项数。

Sample Input 

 3 100
 34 100
 75 250
 27 2147483647
 101 304
 101 303
 -1 -1

Sample Output 

 Case 1: A = 3, limit = 100, number of terms = 8
 Case 2: A = 34, limit = 100, number of terms = 14
 Case 3: A = 75, limit = 250, number of terms = 3
 Case 4: A = 27, limit = 2147483647, number of terms = 112
 Case 5: A = 101, limit = 304, number of terms = 26
 Case 6: A = 101, limit = 303, number of terms = 1
解题思路:按照题目给定公式输入,但是要注意程序是因为超出限制值跳出还是因为等于1跳出
#include<stdio.h>
int main()
{long n,m,i,A,t=1;
while(scanf("%ld%ld",&n,&m)!=EOF){A=n;
                if(n<0&&m<0)break;
                if(n==1)break;
                for(i=0;;)
                {if(n%2==0){n/=2;i++;}
                else {n=(3*n+1);i++;}
                if(n>m)break;
                if(n==1){i++;break;}
                }
                printf("Case %ld: A = %ld, limit = %ld, number of terms = %ld\n",t,A,m,i);
                t++;
                }
return 0;
}

转载于:https://www.cnblogs.com/EVA00/archive/2013/01/31/2887092.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值