Ignatius and the Princess I

 

The Princess has been abducted by the BEelzebub feng5166,our hero Ignatius has to rescue our pretty Princess. Now he gets intofeng5166's castle. The castle is a large labyrinth. To make the problem simply,we assume the labyrinth is a N*M two-dimensional array which left-top corner is(0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and thedoor to feng5166's room is at (N-1,M-1), that is our target. There are somemonsters in the castle, if Ignatius meet them, he has to kill them. Here issome rules: 

1.Ignatius can only move in four directions(up, down, left, right), one stepper second. A step is defined as follow: if current position is (x,y), after astep, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1). 
2.The array is marked with some characters and numbers. We define them likethis: 
. : The place where Ignatius can walk on. 
X : The place is a trap, Ignatius should not walk on it. 
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, ittakes him n seconds to kill the monster. 

Your task is to give out the path which costs minimum seconds for Ignatius toreach target position. You may assume that the start position and the targetposition will never be a trap, and there will never be a monster at the startposition. 

Input

The input contains several test cases. Each test casestarts with a line contains two numbers N andM(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth.Then a N*M two-dimensional array follows, which describe the whole labyrinth.The input is terminated by the end of file. More details in the SampleInput. 

Output

For each test case, you should output "God pleasehelp our poor hero." if Ignatius can't reach the target position, or you shouldoutput "It takes n seconds to reach the target position, let me show youthe way."(n is the minimum seconds), and tell our hero the whole path.Output a line contains "FINISH" after each test case. If there aremore than one path, any one is OK in this problem. More details in the SampleOutput. 

Sample Input

5 6

.XX.1.

..X.2.

2...X.

...XX.

XXXXX.

5 6

.XX.1.

..X.2.

2...X.

...XX.

XXXXX1

5 6

.XX...

..XX1.

2...X.

...XX.

XXXXX.

Sample Output

It takes 13 seconds to reach the targetposition, let me show you the way.

1s:(0,0)->(1,0)

2s:(1,0)->(1,1)

3s:(1,1)->(2,1)

4s:(2,1)->(2,2)

5s:(2,2)->(2,3)

6s:(2,3)->(1,3)

7s:(1,3)->(1,4)

8s:FIGHT AT (1,4)

9s:FIGHT AT (1,4)

10s:(1,4)->(1,5)

11s:(1,5)->(2,5)

12s:(2,5)->(3,5)

13s:(3,5)->(4,5)

FINISH

It takes 14 seconds to reach the targetposition, let me show you the way.

1s:(0,0)->(1,0)

2s:(1,0)->(1,1)

3s:(1,1)->(2,1)

4s:(2,1)->(2,2)

5s:(2,2)->(2,3)

6s:(2,3)->(1,3)

7s:(1,3)->(1,4)

8s:FIGHT AT (1,4)

9s:FIGHT AT (1,4)

10s:(1,4)->(1,5)

11s:(1,5)->(2,5)

12s:(2,5)->(3,5)

13s:(3,5)->(4,5)

14s:FIGHT AT (4,5)

FINISH

God please help our poor hero.

FINISH




#include<bits/stdc++.h>
#include<queue> 
using namespace std;

int N,M;
char maze[110][110];
int vis[110][110];
int way[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};

struct node{
	int x,y;
	int step;
	int time;
	int mov[10010][2];
	
	bool operator < (const node other)const{		//最小值优先 
		return time > other.time;
	}
}; 

void bfs()
{
	priority_queue<node>q;		//优先队列,每次选择耗时最少的先走 
	node cur;
	
	cur.x = 0;
	cur.y = 0;
	cur.step = 0;
	cur.time = 0;
	cur.mov[0][0] = 0;
	cur.mov[0][1] = 0;
	vis[0][0] = 1;
	q.push(cur);
	
	while(!q.empty()){
		cur = q.top();
		q.pop();
			
		
		node tmp;		
		for(int i = 0; i < 4; i++){
			tmp.x = cur.x+way[i][0];
			tmp.y = cur.y+way[i][1];
			
			if (tmp.x < 0 || tmp.y < 0 || tmp.x >= N || tmp.y >= M)
				continue;
				
			if (vis[tmp.x][tmp.y] == 0){
				
				vis[tmp.x][tmp.y] = 1;	
				tmp.step = cur.step+1;		//走的步数 
				tmp.time = cur.time+1;		//到达时间 
				
				if (maze[tmp.x][tmp.y] >= '1' && maze[tmp.x][tmp.y] <= '9'){	//有怪物 
					tmp.mov[tmp.step][0] = tmp.x;
					tmp.mov[tmp.step][1] = tmp.y;
					tmp.time = tmp.time + (maze[tmp.x][tmp.y] - '0');	//战斗时间另算 
				}
				else{
					tmp.mov[tmp.step][0] = tmp.x;
					tmp.mov[tmp.step][1] = tmp.y;
				}
				//到达终点 
				if (tmp.x == N-1 && tmp.y == M-1){
					printf("It takes %d seconds to reach the target position, let me show you the way.\n",tmp.time);
					int time = 1;
					for(int j = 1; j <= tmp.step; j++){
						printf("%ds:(%d,%d)->(%d,%d)\n",time++,tmp.mov[j-1][0],tmp.mov[j-1][1],tmp.mov[j][0],tmp.mov[j][1]);
						if (maze[tmp.mov[j][0]][tmp.mov[j][1]] != '.'){	//遇到怪物 
							for(int k = 0; k < maze[tmp.mov[j][0]][tmp.mov[j][1]]-'0'; k++){
								printf("%ds:FIGHT AT (%d,%d)\n",time++,tmp.mov[j][0],tmp.mov[j][1]);
							}
						}
					}
					
					printf("FINISH\n");
					return ;
				}
				q.push(tmp);
			}
		}
	}
	
	printf("God please help our poor hero.\n");
	printf("FINISH\n");
	
	return;
}

int main()
{
	
	while(~scanf("%d%d",&N,&M)){
		memset(maze,0,sizeof(maze));
		memset(vis,0,sizeof(vis));
		
		for(int i = 0; i < N; i++){
			scanf("%s",maze[i]);
			for(int j = 0; j < M; j++){
				if (maze[i][j] == 'X')
					vis[i][j] = 1;
			}
		}	
		
		bfs();	
		
	}
	
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值