Sum It Up_poj1564_dfs+水

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , … , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , … , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing ‘Sums of’, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

Source

Mid-Central USA 1997

题目大意:

给定值t和n,以及n个数,求和为t的方案数

思路:

身在中山的第一题,dfs水,重点是去重判断,如果当前数字在同一数位出现过就跳过1,否则继续。

剪枝:如果当前累加结果大于t,return

还有就是,数据出奇地小,出乎意料一次过。

代码/c++:

#include <stdio.h>
int f[100]={0};
int p[100]={0};
int b[100]={0};
int n,m,ans;
bool flag;
void print(int t[100],int v)
{
    ans++;
    for (int i=1;i<v-1;i++)
    printf("%d+",t[i]);
    printf("%d\n",t[v-1]);
}
void dfs(int dep,int sum,int last)
{
    if (sum>n) return;
    if (sum==n)
    {
        flag=true;
        print(p,dep);
        return;
    }
    int pre=-1;
    for (int i=last+1;i<=m;i++)
    if (!b[i]&&f[i]!=pre)
    {
        b[i]=1;
        pre=f[i];
        p[dep]=f[i];
        dfs(dep+1,sum+f[i],i);
        b[i]=0;
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    while (n+m>0)
    {
        for (int i=1;i<=m;i++)
        scanf("%d",&f[i]);
        printf("Sums of %d:\n",n);
        flag=false;
        dfs(1,0,0);
        if (!flag) printf("NONE\n");
        scanf("%d%d",&n,&m);
    }
    return 0;
}

  1. 这里给出的是有序数列所以只需要考虑前一情况,否则要判断之前的所有情况。

转载于:https://www.cnblogs.com/olahiuj/p/5781285.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值