POJ 2104: K-th Number

K-th Number

Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 52878 Accepted: 18188
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

题意:

给出n个数,询问区间第k大...

分析:

这题解法有很多...

之前写了整体二分...然后还可以用静态主席树水过...

感觉时间空间复杂度还是差很多的...

Run IDUserProblemResultMemoryTimeLanguageCode LengthSubmit Time
16573738NEIGHTHORN2104Accepted22644K1735MSG++1196B2017-02-12 11:25:34
16456326NEIGHTHORN2104Accepted7672K2829MSG++1492B2017-01-07 11:10:22

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
//by NeighThorn
using namespace std;

const int maxn=100000+5,maxm=10000000+5;

int n,m,len,tot,a[maxn],mp[maxn],ls[maxm],rs[maxm],sum[maxm],root[maxn];

inline int find(int x){
	int l=1,r=len,ans;
	while(l<=r){
		int mid=(l+r)>>1;
		if(mp[mid]>=x)
			ans=mid,r=mid-1;
		else
			l=mid+1;
	}
	return ans;
}

inline void change(int l,int r,int x,int &y,int val){
	y=++tot,sum[y]=sum[x]+1;
	if(l==r)
		return;
	int mid=(l+r)>>1;ls[y]=ls[x],rs[y]=rs[x];
	if(val<=mid)
		change(l,mid,ls[x],ls[y],val);
	else
		change(mid+1,r,rs[x],rs[y],val);
}

inline int query(int l,int r,int x,int y,int num){
	if(l==r)
		return l;
	int mid=(l+r)>>1;
	if(sum[ls[y]]-sum[ls[x]]>=num)
		return query(l,mid,ls[x],ls[y],num);
	else
		return query(mid+1,r,rs[x],rs[y],num-(sum[ls[y]]-sum[ls[x]]));
}

signed main(void){
	scanf("%d%d",&n,&m);
	for(int i=1,x;i<=n;i++)
		scanf("%d",&a[i]),mp[i]=a[i];
	sort(mp+1,mp+n+1);
	len=unique(mp+1,mp+n+1)-mp-1;
	for(int i=1;i<=n;i++)
		change(1,n,root[i-1],root[i],find(a[i]));
	for(int i=1,s,x,y;i<=m;i++)
		scanf("%d%d%d",&x,&y,&s),printf("%d\n",mp[query(1,len,root[x-1],root[y],s)]);
	return 0;
}
//1234

  


By NeighThorn

转载于:https://www.cnblogs.com/neighthorn/p/6390649.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值