HDU 5344 MZL's xor 水题

MZL's xor

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5344

Description

MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)
The xor of an array B is defined as B1 xor B2...xor Bn

Input

Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai−1∗m+z) mod l
1≤m,z,l≤5∗105,n=5∗105

Output

For every test.print the answer.

Sample Input

2
3 5 5 7
6 8 8 9

Sample Output

14
16

Hint

题意

求所有的Ai+Aj的异或值,1<=i,j<=n

题解:

ai+aj这尼玛不是FFT嘛

赶紧莽一波,然后TLE成傻逼了

然后队友提醒我了,(ai+aj)^(aj+ai)=0,其实这是一道智障题……

当时整个人都懵逼了

代码

#include<bits/stdc++.h>
using namespace std;

int n,m,z,l;
void solve()
{
    scanf("%d%d%d%d",&n,&m,&z,&l);
    long long ans = 0;
    long long pre = 0;
    for(int i=0;i<n;i++)
    {
        ans^=2LL*pre;
        pre = (1ll*pre*m+z)%l;
    }
    cout<<ans<<endl;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)solve();
    return 0;
}

转载于:https://www.cnblogs.com/qscqesze/p/5449528.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值