【POJ 3668】Game of Lines

Game of Lines
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6555 Accepted: 2439

Description

Farmer John has challenged Bessie to the following game: FJ has a board with dots marked at N (2 ≤ N ≤ 200) distinct lattice points. Dot i has the integer coordinates Xi and Yi (-1,000 ≤ Xi ≤ 1,000; -1,000 ≤ Yi ≤ 1,000).

Bessie can score a point in the game by picking two of the dots and drawing a straight line between them; however, she is not allowed to draw a line if she has already drawn another line that is parallel to that line. Bessie would like to know her chances of winning, so she has asked you to help find the maximum score she can obtain.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 describes lattice point i with two space-separated integers: Xi and Yi.

Output

* Line 1: A single integer representing the maximal number of lines Bessie can draw, no two of which are parallel.
 

Sample Input

4
-1 1
-2 0
0 0
1 1

Sample Output

4

Source

 
然而此题只是简单的枚举。
枚举一个点和另一个点匹配,并且记录这条直线的斜率,如果发现了斜率曾经出现过就忽略。
注:由于直线可能与y轴平行(即x[i] == x[j])所以此时设为无穷大(然而只是2 31 - 1)。
#include<cstdio>
#include<cstring>
#include<set>
using namespace std;

int x[205];
int y[205];
int n;
set<double> s;

int main()
{
    scanf("%d", &n);
    for (int i = 0; i < n; ++i)
        scanf("%d%d", &x[i], &y[i]);
    int ans = 0;
    s.clear();
    for (int i = 0; i < n; ++i)
        for (int j = i + 1; j < n; ++j)
        {
            double k;
            if (x[i] - x[j] == 0) k = 0x7fffffff;
            else k = (double)(y[i] - y[j]) / (x[i] - x[j]);
            if (!s.count(k))
            {
                ++ans;
                s.insert(k);
            }
        }
    printf("%d\n", ans);
    return 0;
}

 

转载于:https://www.cnblogs.com/albert7xie/p/4743543.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值