POJ 3046 Ant Counting

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

3 sets with 1 ant: {1} {2} {3} 
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
1 set with 5 ants: {1,1,2,2,3} 

Your job is to count the number of possible sets of ants given the data above. 

Input

* Line 1: 4 space-separated integers: T, A, S, and B 

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS: 

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made? 


OUTPUT DETAILS: 

5 sets of ants with two members; 5 more sets of ants with three members
 
 
背包dp
可以优化决策,只贴了优化后的代码。
 
#include<cstdio>

int cnt[1005]={};
int dp[2][100005];
const int MOD = 1000000;

int main(){
    int T, A, S, B, x;
    scanf("%d%d%d%d",&T,&A,&S,&B);
    for(int i=0;i<A;i++)
        scanf("%d",&x),cnt[x]++;

    // dp[i][j] 前 i 种中选 j 个物品可以组成的种数
    // 决策: 不选i 或 至少选一个i
    // 不选的话 显然就是 dp[i-1][j]
    // 选至少一个 dp[i][j-1] - dp[i-1][j-1-cnt[i]]
    dp[0][0] = 1;
    for(int i=1;i<=T;i++){
        dp[i&1][0] = 1;
        for(int j=1;j<=B;j++){
            if(j-cnt[i] > 0)// 无法用单独使用第 i 件物品构建出 j
                dp[i&1][j] =
                (dp[(i+1)&1][j]+dp[i&1][j-1]-dp[(i+1)&1][j-1-cnt[i]]+MOD)%MOD;
            else
                dp[i&1][j] = (dp[(i+1)&1][j] + dp[i&1][j-1])%MOD;
            // 第 i 件物品 >= j 所以可以用 j-1 件 i 之前的物品加上一件 i 构建 j
            // 可以单独用 j-1 件物品(这些物品可以由 k 组成 k <= i)
            // 加上一件 i 构建 j

        }
    }
    int ans = 0;
    for(int i=S;i<=B;i++)
        ans += dp[T&1][i];
    printf("%d\n",ans%MOD);
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/kongbb/p/10459268.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值