动态规划:HDU3496-Watch The Movie(二维费用的背包问题)

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 7811    Accepted Submission(s): 2496

Problem Description

New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.

 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.

 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.

 

Sample Input
 
  
1 3 2 10 11 100 1 2 9 1
 

Sample Output
 
  
3
 


解题心得:

1、这个题感觉真的好多坑,虽然知道是二维费用的背包问题但是还是错的很悲伤。先来数数这个题的坑。第一,首先被英语给坑了一把,题目要求是恰好m个片的时候不超过时间L的最大的价值,第二,这个题的价值可能是负数,所以在dp初始化的时候不能初始化为零,第三这个题只能使用二维数组,不能使用结构体来模拟,当时在想这个题的时候没用使用二维数组来做,用的结构体,但是很惨。后来找到了BUG,就不多说了,说说二维数组。


2、二维数组dp[i][j],i表示当前有I张片子,使用了j的时间的最高的价值。可以看成一个0-1背包问题,里面的内层循环用二维数组,改成一个两层循环,思维还是没怎么变,只是实现方法变了一下。


#include<bits/stdc++.h>
using namespace std;
const int maxn1 = 105;
const int maxn2 = 1010;
const int Min = -0x7f7f7f7f;
int dp[maxn1][maxn2];
struct Res
{
    int va;
    int time;
}res[maxn1];
int main()
{
    int n,m,l;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&l);
        for(int i=1;i<=n;i++)
            scanf("%d%d",&res[i].time,&res[i].va);
        for(int i=0;i<=m;i++)
            for(int j=0;j<=l;j++)
                dp[i][j] = Min;
        for(int i=0;i<=l;i++)
            dp[0][i] = 0;
        for(int i=1;i<=n;i++)
            for(int j=m;j>=1;j--)//可以把以下的二维循环看成0-1背包问题的内层循环
                for(int k=l;k>=res[i].time;k--)
                    dp[j][k] = max(dp[j][k],dp[j-1][k-res[i].time]+res[i].va);

        if(dp[m][l] < 0)
            printf("0\n");
        else
            printf("%d\n",dp[m][l]);
    }
}


 

转载于:https://www.cnblogs.com/GoldenFingers/p/9107330.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值