Hash和枚举 解决POJ 1840

 

Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
 
 
 

 

用这个来做hash的入门是再好不过了

在网上也看到很有关hash的代码,但是

总是看不懂呀,心里老是不明白是怎么

一回事,自从看到这个代码之后,一下就

大悟了。哈哈。

 

View Code
View Code 

#include <iostream>
#include <cmath>
#define size  200005
using namespace std;

int hash[size][10],num[size];

int main()
{
    memset(num, 0, sizeof(num));
    int i,j,k,l;
    int count=0;
    int temp,mark;
    int a[5];
    scanf("%d%d%d%d%d",&a[0],&a[1],&a[2],&a[3],&a[4]);

    for(i=-50;i<=50;i++)
        for(j=-50;j<=50;j++){
            if(i!=0 && j!=0){
                temp=a[0]*i*i*i+a[1]*j*j*j;
                mark=abs(temp)%size;//设置key值
                hash[mark][num[mark]]=temp;//建立哈希表:mark为key信息,temp为要存储的信息
                num[mark]++;//防止冲突
            }
        }
    for(i=-50;i<=50;i++)
        for(j=-50;j<=50;j++)
            for(k=-50;k<=50;k++){
                if(i!=0 && j!=0 && k!=0){
                   temp=a[2]*i*i*i+a[3]*j*j*j+a[4]*k*k*k;
                    mark=abs(temp)%size;
                    for(l=0;l<num[mark];l++){ //匹配
                        if(temp==hash[mark][l])
                            count++;
                    }
                }
            }
    printf("%d\n",count);
    return 0;
}

 

 

 

 

转载于:https://www.cnblogs.com/o8le/archive/2011/09/26/2192187.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值