1058. A+B in Hogwarts (20)

题目如下:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28


设计一个结构体存储G、S、K三位,根据题目条件进位即可。

#include <iostream>
#include <stdio.h>

using namespace std;

struct GSK{
    int G;
    int S;
    int K;

    void add(GSK other){
        int carry;
        K += other.K;
        carry = K / 29;
        K = K % 29;
        S = S + carry + other.S;
        carry = S / 17;
        S = S % 17;
        G = G + carry + other.G;
    }

};

int main()
{
    GSK n1,n2;
    scanf("%d.%d.%d",&n1.G,&n1.S,&n1.K);
    scanf("%d.%d.%d",&n2.G,&n2.S,&n2.K);
    n1.add(n2);
    printf("%d.%d.%d",n1.G,n1.S,n1.K);
    return 0;
}


转载于:https://www.cnblogs.com/aiwz/p/6154110.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值