FZU 1759 Super A^B mod C (超级快速幂)

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,C<=1000000000,1<=B<=10^1000000).

Input
There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output
For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input
3 2 4
2 10 1000
Sample Output
1
24

题意:快速幂(其中幂指数特别大,long  long也装不下,需要用字符串输入)

解法:

那个是欧拉函数

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
typedef long long ll;
using namespace std;
ll quckpow(ll m,ll n,ll k)
{
    ll b=1;
    while(n>0)
    {
        if(n&1)b=(b*m)%k;
        n=n>>1;
        m=(m*m)%k;
    }return b;
}
ll phi(ll n)
{
    ll i,rea=n;
    for(i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            rea=rea-rea/i;
            while(n%i==0)n/=i;
        }
    }
    if(n>1)
        rea=rea-rea/n;
    return rea;
}
char b[1000050];
int main()
{
    ll a,c,ans;
    while(scanf("%I64d%s%I64d",&a,b,&c)!=-1)
    {
        int len=strlen(b);
        ll ph,t;
        ph=phi(c);
        if(len<=20)
        {
           sscanf(b, "%I64d", &t);
            if(t>=ph)
                t=t%ph+ph;
            ans=quckpow(a,t,c);
        }
        else
        {
            t=0;
            for(int i=0;i<len;i++)
            {
                t=t*10+b[i]-'0';
                if(t>ph)
                    t=t%ph;

            }ans=quckpow(a,t,c);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值