PAT1052:Linked List Sorting

1052. Linked List Sorting (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

思路
链表排序。
1.先储存所有输入节点到一个dic中(map模拟)。
2.根据给定的头结点遍历链表并将访问到的节点插入一个新的序列(vector)中。这个过程能筛掉dic中不在链表中的节点。
3.对新序列根据key值排序。
4.按照新排列的顺序修改每个节点指向的next地址
5.输出:
1)注意地址格式为标准5位数
2)如果新序列为空,输出"0 -1"。
3)最后末尾节点的next地址直接输出-1,而不是5位的格式"-00001"。
代码
#include<vector>
#include<algorithm>
#include<iostream>
#include<map>
using namespace std;
class node
{
public:
   int address;
   int key;
   int next;
};
map<int,node> dic;
vector<node> nodes;
bool cmp(const node& a,const node& b)
{
    return a.key < b.key;
}

int main()
{
   int N,head;
   while(cin >> N >> head)
   {
       for(int i = 0;i < N;i++)
       {
           int ad;
           cin >> ad;
           dic[ad].address = ad;
           cin >> dic[ad].key >> dic[ad].next;
       }
       while(head != -1)
       {
           nodes.push_back(dic[head]);
           head = dic[head].next;
       }
       sort(nodes.begin(),nodes.end(),cmp);
       int len = nodes.size();
       if(len == 0)
       {
           cout << "0 -1" << endl;
           continue;
       }
       for(int i = 1;i < len;i++)
       {
           nodes[i - 1].next = nodes[i].address;
       }
       nodes[len - 1].next = -1;
       head = nodes[0].address;
       //output
       printf("%d %05d\n",len,head);
       for(int i = 0;i < len;i++)
       {
           if(i == len - 1)
             printf("%05d %d -1\n",nodes[i].address,nodes[i].key);
           else
             printf("%05d %d %05d\n",nodes[i].address,nodes[i].key,nodes[i].next);
       }
   }
}

  

转载于:https://www.cnblogs.com/0kk470/p/8134366.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值