Milking Grid@POJ 2185

Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.
 

Input

* Line 1: Two space-separated integers: R and C

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character.

Output

* Line 1: The area of the smallest unit from which the grid is formed

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern 'AB'.

 

题目分析:这道题也是要利用nex数组寻找最短循环节。区别是允许最后一段可以是残缺的,即循环次数可以不是整数。比如abcd循环2.5次就是abcdabcdab,那么len-(nex[len-1]+1)就是我们要求的最短循环节的长度。

因为这道题是二维的,解决二维矩阵的关键是我们要知道在二维矩阵中循环在x和y两个方向上是独立的,可以分别计算。

也就是沿x和y方向分别做求两次nex数组,最后两循环节长度相乘就是答案。

 

#include <algorithm>
#include <iostream>
#include <string>
#include <vector>
#include <cstring>
#include <cstdio>
#define MAXN 10003
using namespace std;

char s[MAXN][MAXN/100];
int nex[MAXN];
int n,m;

bool equalc(int c1,int c2){
    for(int i=0;i<n;++i){
        if(s[i][c1] != s[i][c2]) return false;
    }
    return true;
}

bool equalr(int r1,int r2){
    for(int i=0;i<m;++i){
        if(s[r1][i] != s[r2][i]) return false;
    }
    return true;
}

int get_cnex(){
    nex[0] = -1;
    int k = -1;
    for(int i=1;i<m;++i){
        while(k>-1 && !equalc(k+1,i)) k = nex[k];
        if(equalc(k+1,i)) ++k;
        nex[i] = k;
    }
    return m-(nex[m-1]+1);
}

int get_rnex(){
    nex[0] = -1;
    int k = -1;
    for(int i=1;i<n;++i){
        while(k > -1 && !equalr(k+1,i)) k = nex[k];
        if(equalr(k+1,i)) ++k;
        nex[i] = k;
    }
    return n-(nex[n-1]+1);
}


int main(){
    while(~scanf("%d%d",&n,&m)){
        for(int i=0;i<n;++i) scanf("%s",s[i]);
        int ans = get_cnex(); //沿x方向求循环节长度
        ans *= get_rnex(); //沿y方向
        cout << ans << endl;
    }
    return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
02-12

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值