PAT 1059. Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

分析

在输入的数据为1时输出1=1;
#include<iostream>
#include<math.h>
#include<map>
using namespace std;
bool isprime(long int n){
    for(int i=2;i<=sqrt(n);i++)
        if(n%i==0) return false;
    return true;
}
int main(){
    long int p,t=1,q;
    cin>>p;
    q=p;
    map<long int,int> mapp; 
    for(int i=2;i<=p;i++){
        while(isprime(i)&&p%i==0){
             p/=i;
             t*=i;
             mapp[i]++;
        }
        if(t==q) break;
    }
    printf("%d=",q);
    if(q==1) printf("1");
    for(auto it=mapp.begin();it!=mapp.end();it++){
        if(it!=mapp.begin()) 
           printf("*");
        if(it->second==1)
           printf("%d",it->first);
        else
           printf("%d^%d",it->first,it->second);
    }
    return 0;
} 

转载于:https://www.cnblogs.com/A-Little-Nut/p/8365366.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值