HDU - 4597 Play Game(博弈dp)

Play Game

 

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

InputThe first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤bi≤10000).OutputFor each case, output an integer, indicating the most score Alice can get.Sample Input

2 
 
1 
23 
53 
 
3 
10 100 20 
2 4 3 

Sample Output

53 
105 



dp[al][ar][bl][br]记录的是在a的区间只剩下al~ar,b的区间只剩下bl~br的时候,Alice能得到的最大值
那么只需要考虑四种不同的取法并从中取得最优的方案,sum-(Alice上一个状态中Bob拿的值)中取最大
 
 
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;

int a[25],b[25];
int dp[25][25][25][25];

int dfs(int al,int ar,int bl,int br,int sum){
    if(al>ar&&bl>br){
        return 0;
    }
    if(dp[al][ar][bl][br]>-1) return dp[al][ar][bl][br];
    int ma=0;
    if(al<=ar){
        ma=max(ma,sum-dfs(al+1,ar,bl,br,sum-a[al]));
        ma=max(ma,sum-dfs(al,ar-1,bl,br,sum-a[ar]));
    }
    if(bl<=br){
        ma=max(ma,sum-dfs(al,ar,bl+1,br,sum-b[bl]));
        ma=max(ma,sum-dfs(al,ar,bl,br-1,sum-b[br]));
    }
    dp[al][ar][bl][br]=ma;
    return ma;
}
int main()
{
    int t,n,i,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int sum=0;
        for(i=1;i<=n;i++){
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        for(i=1;i<=n;i++){
            scanf("%d",&b[i]);
            sum+=b[i];
        }
        memset(dp,-1,sizeof(dp));
        printf("%d\n",dfs(1,n,1,n,sum));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yzm10/p/10328605.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值