Play Game HDU - 4597

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai(1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2 
 
1 
23 
53 
 
3 
10 100 20 
2 4 3 

Sample Output

53 
105 

 

思路:

dp[l1][r1][l2][r2]:表示先手从第一堆里[l1,r1],第二堆[l2,r2]中拿到的最大分数之和。

dp[l1][r1][l2][r2]的上一 一个状态dp[l1+1][r1][l2][r2]、dp[l1][r1-1][l2][r2]、dp[l1][r1][l2+1][r2]、dp[l1][r1][l2][r2-1] ,即bob拿到,答案max{sum[l1][r1][l2][r2]-bob拿到的}

 

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;

const int N=50;
const int M=100005;
int a,b,f[N][N][N][N],suma[N],sumb[N];

int solve(int l1, int r1, int l2, int r2){//记忆化搜索
    if(f[l1][r1][l2][r2]!=-1){
        return f[l1][r1][l2][r2];
    }
    if(l1>r1||l2>r2) f[l1][r1][l2][r2]=0;
    int sum=0,ans=0;
    if(l1<=r1){
       sum+=suma[r1]-suma[l1-1];
    }
    if(l2<=r2){
       sum+=sumb[r2]-sumb[l2-1];
    }
    if(l1<=r1){
       ans=max(ans,sum-solve(l1+1,r1,l2,r2));
       ans=max(ans,sum-solve(l1,r1-1,l2,r2));
    }
    if(l2<=r2){
       ans=max(ans,sum-solve(l1,r1,l2+1,r2));
       ans=max(ans,sum-solve(l1,r1,l2,r2-1));
    }

    return f[l1][r1][l2][r2]=ans;;
}
int main()
{
    int t,n;
    cin>>t;
    while(t--){
       cin>>n;
       suma[0]=0;
       sumb[0]=0;
       memset(f,-1,sizeof(f));
       for(int i=1; i<=n; i++){
            cin>>a;
            suma[i]=suma[i-1]+a;
       }
       for(int i=1; i<=n; i++){
            cin>>b;
            sumb[i]=sumb[i-1]+b;
       }
       cout<<solve(1,n,1,n)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值