hdu2099 整除的位数(暴力)

一个整数,仅仅知道前几位。不知道末二位,被还有一个整数除尽了,那么该数的末二位该是什么呢?
 
Input
输入数据有若干组,每组数据包括二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

Output
相应每组数据,将满足条件的全部尾数在一行内输出,格式见样本输出。

同组数据的输出,其每一个尾数之间空一格,行末没有空格。

 

Sample Input
 
   
200 40 1992 95 0 0
 

Sample Output
 
   
00 40 80 15 题目分析; 直接暴力就可以。 AC代码:
/**
 *直接暴力模拟
 */
#include<iostream>
#include<cstdio>
#include<map>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cctype>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
    int a,b,s;
    while(cin>>a>>b&&(a+b>0)){
        int ok=0;//控制输出空格
        for(int i=0;i<=9;i++){
            for(int j=0;j<=9;j++){
                s=a*100+i*10+j;
                if(s%b==0){
                    if(!ok){
                        cout<<i<<j;
                        ok=1;
                    }
                    else cout<<" "<<i<<j;
                }
            }
        }
        cout<<endl;
    }
    return 0;
}


转载于:https://www.cnblogs.com/lxjshuju/p/6895466.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值