### 思维

6539: ###

时间限制: 1 Sec  内存限制: 128 MB
提交: 50  解决: 19
[提交][状态][讨论版][命题人:admin]

题目描述

On a two-dimensional plane, there are m lines drawn parallel to the x axis, and n lines drawn parallel to the y axis. Among the lines parallel to the x axis, the i-th from the bottom is represented by y=yi. Similarly, among the lines parallel to the y axis, the i-th from the left is represented by x=xi.
For every rectangle that is formed by these lines, find its area, and print the total area modulo 109+7.
That is, for every quadruple (i,j,k,l) satisfying 1≤i<j≤n and 1≤k<l≤m, find the area of the rectangle formed by the lines x=xi, x=xj, y=yk and y=yl, and print the sum of these areas modulo 109+7.

Constraints
2≤n,m≤105
−109≤x1<…<xn≤109
−109≤y1<…<ym≤109
xi and yi are integers.

输入

Input is given from Standard Input in the following format:
n m
x1 x2 … xn
y1 y2 … ym

输出

Print the total area of the rectangles, modulo 109+7.

样例输入

3 3
1 3 4
1 3 6

样例输出

60

提示

The following figure illustrates this input:

The total area of the nine rectangles A, B, ..., I shown in the following figure, is 60.

计算n条平行于x轴的直线 与 m条平行于y轴的直线 所围成的所有矩形的面积和 (xi-xj) * (yi-yj)

发现x与y方向的面积可以分开各自计算  (i-1)*xi-(n-i)*xi

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int MAX=1e5+100;
const int INF=99999999;
const int MOD=1e9+7;
ll x[MAX],y[MAX];
int main()
{
    ll n,m;
    cin>>n>>m;
    for(int i=1; i<=n; i++){
        cin>>x[i];
    }
    for(int i=1; i<=m; i++){
        cin>>y[i];
    }
    ll ax=0,ay=0;
    for(int i=1; i<=n; i++){
        ax=(ax+((i-1)*x[i]- (n-i)*x[i]))%MOD;
    }
    for(int i=1; i<=m; i++){
        ay=(ay+((i-1)*y[i]-(m-i)*y[i]))%MOD;
    }
    cout<<ax%MOD*ay%MOD<<endl;
    return 0;
}

 

 

转载于:https://www.cnblogs.com/renxiaomiao/p/9642699.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值