poj 3070 矩阵快速幂求斐波拉契数列

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12324 Accepted: 8746

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


题意:给出一个求斐波拉契数列的矩阵,Fn即为进行n次矩阵乘法后得到矩阵的a[0][1],让你用矩阵乘法来求斐波拉契数列

思路:将快速幂运用到矩阵上,非常通俗的方法。其实这道题拓神在去年的讲课上就已经说过了,当时回来就手敲了一个,一直不知道竟然在POJ上有题……今天改了一下交了下。虽然真的是手敲……


代码

#include<stdio.h>
int ans[2][2];
void kuaisumi(long long b)
{
  long long temp[2][2];
  long long templ[2][2];
 // for(int i=0;i<2;i++)
   // for(int j=0;j<2;j++)
	 // temp[i][j]=a[i][j]; 
  ans[0][0]=1;
  ans[0][1]=1;
  ans[1][0]=1;
  ans[1][1]=0; 
  temp[0][0]=1;
  temp[0][1]=1;
  temp[1][0]=1;
  temp[1][1]=0;
  while(b>0)
     {if(b%2==1)
	   {templ[0][0]=ans[0][0]%10000*temp[0][0]%10000+ans[0][1]%10000*temp[1][0]%10000;
	    templ[0][1]=ans[0][0]%10000*temp[1][0]%10000+ans[0][1]%10000*temp[1][1]%10000;
	    templ[1][0]=ans[1][0]%10000*temp[0][0]%10000+ans[1][1]%10000*temp[1][0]%10000;
	    templ[1][1]=ans[1][0]%10000*temp[0][1]%10000+ans[1][1]%10000*temp[1][1]%10000;
	    for(int i=0;i<2;i++)
          for(int j=0;j<2;j++)
	          ans[i][j]=templ[i][j]%10000; 
	     }
      b=b/2;
	    templ[0][0]=temp[0][0]%10000*temp[0][0]%10000+temp[0][1]%10000*temp[1][0]%10000;
	    templ[0][1]=temp[0][0]%10000*temp[1][0]%10000+temp[0][1]%10000*temp[1][1]%10000;
	    templ[1][0]=temp[1][0]%10000*temp[0][0]%10000+temp[1][1]%10000*temp[1][0]%10000;
	    templ[1][1]=temp[1][0]%10000*temp[0][1]%10000+temp[1][1]%10000*temp[1][1]%10000;	
	    for(int i=0;i<2;i++)
          for(int j=0;j<2;j++)
	          temp[i][j]=templ[i][j]%10000;
	 }
   	 
}
int main()
{
int juzheng[3][3];
long long i,j,k,m,n;
int fm,fn;
int f1,f2;
 f1=1;
 f2=1;
 while(scanf("%lld",&n)!=EOF)
  {if(n==-1)break;
   if(n==0)printf("0\n");
   else 
   if(n==1 || n==2)printf("1\n");
   else
   { kuaisumi(n-2);
     printf("%lld\n",(ans[0][0])%10000);
     }
    }   
 return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值