Problem Description
Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.
For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.
Input
The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.
Output
The output will contain the minimum number N for which the sum S can be obtained.
Sample Input
12
Sample Output
7
思路:
sum:从1到n的和
sum1:负数的和
T:给定的值
sum-2*sum1=T;===》(sum-T)%2 =0
代码:
```c
#include<stdio.h>
int main()
{
int T;
scanf("%d",&T);
int i=0,sum=0;
while(1)
{
sum+=++i;
if((sum-T)%2==0&&sum>T)
break;
}
printf("%d\n",i);
return 0;
}