Sum

Problem Description

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

题目大意:对于连续自然数,对其做+或-运算,求最少运算次数得到所得数

解题思路:S=i*(i+1)/2,每做一次减运算都相当比原先那个数少个偶数。即
(S-n)%2==0即可。

代码:

#include<stdio.h>
#include<math.h>
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int i,sum;
        for(i=1;i<=n ;i++)
        {
            sum=(i+1)*i/2;
            if(sum>=n&&(sum-n)%2==0)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值