HDU-1379 DNA Sorting 简单排序

DNA Sorting

                                                                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                                               Total Submission(s): 854    Accepted Submission(s): 442


Problem Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
 

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.
 

Sample Input
1

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
 

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
 
  数据很弱,该题要求输出稳定排序,所以这里采用了bobblesort,看了大家都是 0MS过的,呵呵,暴力去!!
  代码如下:
#include <iostream>

using namespace std;

char str[105][55];

int rec[105][2]; // 0 号元素用来存储下标,1 号元素用来存储逆序值

int get( char *s, int len )
{
	int ans= 0;
	for( int i= 0; i< len- 1; ++i )
	{
		for( int j= i+ 1; j< len; ++j )
		{
			if( s[i]> s[j] )
			{
				ans++;	
			}
		}
	}
	return ans;
}

void swap( const void *a, const void *b, int size )
{
    	char *x= ( char * )a, *y= ( char * )b;
	for( int i= 0; i< size; ++i )
	{
		char c= *x;
		*x= *y;
		*y= c;
		x+= 1, y+= 1;
	}
	return;
}

void bsort( int rec[][2], int m )
{
	for( int i= 0; i< m- 1; ++i )
	{
		for( int j= 0; j< m- i- 1; ++j )
		{
			if( rec[j][1]> rec[j+ 1][1] )
			{
				swap( rec[j], rec[j+ 1], sizeof( rec[0] ) );
			}
		}
	}
	return;
}

int main(  )
{
	int N;
	cin>>N;
	while( N-- )
	{
		int n, m;
		cin>> n>> m;
		for( int i= 0; i< m; ++i )
		{
			cin>> str[i];
			rec[i][0]= i;
			rec[i][1]= get( str[i], n );
//			cout<< rec[i][1]<< endl;
		}
		bsort( rec, m );
		for( int i= 0; i< m; ++i )
		{
			cout<< str[ rec[i][0] ]<< endl;
		}
		if( N> 1 )
		{
			cout<< "\n";
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值