一个大数加法问题


A+B Problem II

时间限制:3000 ms  |  内存限制:65535 KB

难度:3

  • 描述

  • I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    A,B must be positive.

    • 输入

    • The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    • 输出

    • For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.

    • 样例输入

    • 2
      1 2
      112233445566778899 998877665544332211
    • 样例输出

    • Case 1:
      1 + 2 = 3
      Case 2:
      112233445566778899 + 998877665544332211 = 1111111111111111110


#include <iostream>
#include <cstring>
#include <string>

using namespace std;

int main()
{
	int n,s_m1[1010],s_m2[1010],s[1010],len1,len2,max,i,j,nCase=1;
	string m1,m2;
	cin>>n;
	while(n--)
	{
		cin>>m1>>m2;
		
		memset(s_m1,0,sizeof(s_m1));
		memset(s_m2,0,sizeof(s_m2));
		memset(s,0,sizeof(s));

		len1=m1.length();
		len2=m2.length();
		
		for(i=0;i<len1;i++)
			s_m1[i]=(m1[len1-i-1]-'0');
		
		for(i=0;i<len2;i++)
			s_m2[i]=(m2[len2-i-1]-'0');
		
		max=(len1>len2) ? len1:len2;
		
		j=0;
		for(i=0;i<max;i++)
		{
			s[i]=(s_m1[i]+s_m2[i]+j)%10;
			j=(s_m1[i]+s_m2[i]+j)/10;
		}

		cout<<"Case "<<nCase++<<":"<<endl;
		cout<<m1<<" + " <<m2<<" = ";
		
		if(j)
			cout<<"1";
		while(i>0)
			cout<<s[--i];
		cout<<endl;
	}
	return 0;
}