nyoj103A+B Problem II

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
可以作为一个模板使用:
#include <stdio.h>
#include <string.h>
int main()
{
    int n, ia, ib, i, j, temp, len_a, len_b, flag, count = 1;
    scanf("%d", &n);
    char a[10011], b[1011], c[10050];
    while(n--)
    {
        getchar();
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        scanf("%s %s", a, b);
        len_a = strlen(a);
        len_b = strlen(b);
        for(ia = len_a - 1, ib = len_b - 1, i = 0; ia >= 0 && ib >= 0; ia--, ib--, i++)
            c[i] = a[ia] - '0' + b[ib] - '0';//逐个想加,存入一个新数组
        while(ia >= 0)//倘若其中一个数组没有加完,则继续添加
        {
            c[i]= a[ia]- '0';
            ia--;
            i++;
        }
        while(ib >= 0)
        {
            c[i] = b[ib] - '0';
            ib--;
            i++;
        }
        flag = 0;
        for(j = 0; j < i; j++)//对新数组进行处理,进位
        {
            temp = c[j] + flag;
            c[j] = temp % 10;
            flag = temp / 10;
        }
        while(flag != 0)//处理最后一个进位没有处理完的情况
        {
            c[i] = flag % 10;
            flag /= 10;
            i++;
        }
        printf("Case %d:\n%s + %s = ", count, a, b);
        for(j = i - 1; j >= 0; j--)
            printf("%d", c[j]);
        printf("\n");
        count++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值