1. rip协议
默认管理距离为120;利用UDP来封装数据,用UDP 520端口发送接受更新。
rip适用于小型网络,路由器数目不大于15台(默认16台不可达),每30秒更新路由表一次,广播更新。
V2不能接收V1的路由 V1能够接收V2的路由 V1可以兼容V2的路由
V1不支持VLSM  广播更新
V2 组播地址224.0.0.9  组播路由更新 支持可变长子网掩码
 
实验目标: R1 R3 上运行RIP-V1 R2运行RIP2 ,1.0网段运行静态路由
2.0\3.0网段运行RIP down掉任意一个接口都能通信
 
基本配置
R1
interface loopback 0
ip address 1.1.1.1 255.255.255.0
no shutdown
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
no sh
interface s1/1
ip address 192.168.2.1 255.255.255.0
no sh
 
R2
interface s1/1
ip address 192.168.2.2 255.255.255.0
ip rip send version 1
ip rip receive version 1
clock rate 64000
no sh
interface s1/0
ip address 192.168.3.1 255.255.255.0
ip rip send version 1   发送
ip rip receive version 1  接收

clock rate 64000
no sh
 
R3
interface loopback 0
ip address 2.2.2.2 255.255.255.0
no shutdown
interface s1/0
ip address 192.168.3.2 255.255.255.0
no sh
interface Ethernet0/0
ip address 192.168.1.2 255.255.255.0
no sh
 
RIP
R1
ip route 0.0.0.0 0.0.0.0 192.168.1.2  做一条默认路由
router rip
redistribute static metric 1
network 1.0.0.0
network 192.168.2.0

R2
router rip
version 2   运行V2
network 192.168.2.0
network 192.168.3.0
 
R3
ip route 0.0.0.0 0.0.0.0 192.168.1.1
router rip
redistribute static metric 1 发布静态路由
network 2.2.2.0
network 192.168.3.0
 
测试
show ip rip database
show ip route rip
show ip inter brief
debug ip rip