Counting Triangles

Description


Given an equilateral triangle with n the length of its side, program to count how many triangles in it. 


 



  


Input


The length n (n <= 500) of the equilateral triangle's side, one per line. 

process to the end of the file 


  


Output


The number of triangles in the equilateral triangle, one per line. 


  


Sample Input


 1
2
3 


  


Sample Output


 1
5

 

图...就是高中学归纳证明的一道题目吧....我也不会,百度了一波

#include<cstdio>
#include<cstring>
using namespace std;
int long long a[505],b[505],sum[505];
int main()
{ 
    int i,j,n;
  for(i=1;i<=500;i++)
   a[i]=i+a[i-1];
  for(i=2;i<=500;i++)
   b[i]=i-1+b[i-2];
  for(i=1;i<=500;i++)
   sum[i]=sum[i-1]+a[i]+b[i];
  while(scanf("%d",&n)!=EOF)
   printf("%lld\n",sum[n]);
  return 0;
}

 

转载于:https://www.cnblogs.com/liufei-/p/9338769.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值