[解题报告]264 - Count on Cantor

 Count on Cantor 

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

 

displaymath27

 

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

 

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to tex2html_wrap_inline29 and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

 

The input list contains a single number per line and will be terminated by end-of-file.

 

Sample input

 

3
14
7

 

Sample output

 

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4




先锁定N在那个斜行,在根据所在斜行第一个数的编号和下一斜行的第一个编号确定
#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i=1,j=0;
        int k,temp1,temp2,temp3;
        for(k=1;;k++)
   {
       j=i+k;
       if(n>=i&&n<j)
       {
           temp1=k;//所在斜行
           temp2=i;//所在斜行第一个数
           temp3=j;//所在斜行下一行第一个数
           break;
       }
       i=j;
   }
        if(temp1%2==0) printf("TERM %d IS %d/%d\n",n,n-temp2+1,temp1+1-(n-temp2+1));
        else printf("TERM %d IS %d/%d\n",n,temp3-n,temp1+1-(temp3-n));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/TheLaughingMan/archive/2013/02/24/2923072.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值