HDoj-1042 大数阶乘

N!
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53785    Accepted Submission(s): 15217

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!


Input
One N in one line, process to the end of file.


Output
For each N, output N! in one line.

 
Sample Input
1
2
3
 

Sample Output
1
2
6

#include<stdio.h> 
#include<string.h>
const int maxn=50000;    //数组开到50000就能够满足10000的阶乘不越界 
int fun[maxn];
int main()
{
	int i,j,n;
	while(~scanf("%d",&n))
	{
 
	   memset(fun,0,sizeof(fun));
	   fun[0]=1;
	   for(i=2;i<=n;i++)          //从2的阶乘開始,一直到指定数的阶乘 
	   {
		   int c=0;
	    	for(j=0;j<maxn;j++)  //将所得阶乘数放在fun数组中,低位放在fun[0]中 
	    	{
			    int s=fun[j]*i+c;
		      	fun[j] =s%10;
		      	c=s/10;
	        }
       }
       
	  for(j=maxn-1;j>=0;j--)     //找出该数的最高位,即数组角码最大且不为0的数  
	           if(fun[j])  break;
	  for(i=j;i>=0;i--)  
	          printf("%d",fun[i]);
 	  printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值