HDU NPY and arithmetic progression(BestCoder Round #22)

Problem Description:
NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers,  a1,a2,a3,a4, which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
 
Input:
The first line contains a integer T — the number of test cases ( 1T100000).
The next T lines,each contains 4 integers a1,a2,a3,a4(0a1,a2,a3,a4109).
 
Output:
For each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).
 
Sample Input:
3
1 2 2 1
1 0 0 0
3 0 0 0
 
Sample Output:
Yes
No
Yes
 
Hint:
In the first case,the numbers can be divided into {1,2,3} and {2,3,4}. In the second case,the numbers can't be divided properly. In the third case,the numbers can be divided into {1,1,1}.
 
题意:给出a,b,c,d,代表数字1,2,3,4的个数,现在要判断这些数字完全能否组成等差数列(每个数字要用完),因为只有1,2,3,4这四个数,所以等差数列只有1,1,1;  2,2,2;  3,3,3;  4,4,4;  1,2,3;  2,3,4;  1,2,3,4。
#include<stdio.h>
#include<string.h>
#include<queue>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

const int N=1e6+10;
const int INF=0x3f3f3f3f;
const int MOD=1e9+7;

typedef long long LL;

int Judge(int a, int b, int c, int d)
{
    if ((a >= 3 || a == 0) && (b >= 3 || b == 0) && (c >= 3 || c == 0) && (d >= 3 || d == 0))
        return 1; ///如果有三个一样的数就可以组成一个等差数列了;当所有数都被用完时,肯定可以被分的完全

    if (a >= 1 && b >= 1 && c >= 1 && d >= 1)
    {
        if (Judge(a-1, b-1, c-1, d-1)) ///组成1,2,3,4的等差数列
            return 1;
    }

    if (b >= 1 && c >= 1 && d >= 1)
    {
        if (Judge(a, b-1, c-1, d-1)) ///组成2,3,4的等差数列
            return 1;
    }

    if (a >= 1 && b >= 1 && c >= 1)
    {
        if (Judge(a-1, b-1, c-1, d)) ///组成1,2,3的等差数列
            return 1;
    }

    return 0;
}
int main ()
{
    int T, i, ans, a[10];

    scanf("%d", &T);

    while (T--)
    {
        for (i = 0; i < 4; i++)
            scanf("%d", &a[i]);

        ans = Judge(a[0], a[1], a[2], a[3]);

        if (ans == 1) printf("Yes\n");
        else printf("No\n");
    }

    return 0;
}

转载于:https://www.cnblogs.com/syhandll/p/4950289.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值