PKU_1258 Agri-Net

Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

Sample Output

28

 

算法: 

    图的最小生成树

 

思路分析:

    直接求得所给图的最小生成树。

 

代码:

#include <stdio.h>
#include <stdlib.h>

#define MAX_FARMS_NUM 101

typedef struct edge_s {
	int start;
	int end;
	int weight;
} edge_t;

typedef struct disjoint_set_s {
	int rank;
	int parent;
} disjoint_set_t;

disjoint_set_t sets[MAX_FARMS_NUM];
edge_t edges[MAX_FARMS_NUM * MAX_FARMS_NUM / 2];
int edge_num;
int farm_num;

int qsort_cmp(const void *p, const void *q)
{
	return ((edge_t *)p)->weight - ((edge_t *)q)->weight;
}

void sets_init(int set_num)
{
	int i = 0;
	for (i=0; i<set_num; i++) {
		sets[i].rank = 1;
		sets[i].parent = i;
	}
}

int sets_find(int a)
{
	if (sets[a].parent != a) {
		sets[a].parent = sets_find(sets[a].parent);
	}
	return sets[a].parent;
}

void sets_union(int a, int b)
{
	int root_a = sets_find(a);
	int root_b = sets_find(b);
	if (root_a != root_b) {
		if (sets[root_a].rank < sets[root_b].rank) {
			sets[root_a].parent = root_b;
		} else if (sets[root_a].rank > sets[root_b].rank) {
			sets[root_b].parent = root_a;
		} else {
			sets[root_b].parent = root_a;
			sets[root_b].rank++;
		}
	}
}

int main(int argc, char **argv)
{
	int i, j, tmp, result;
	while (scanf("%d", &farm_num) != EOF) {
		edge_num = 0;
		for (i=0; i<farm_num; i++) {
			for (j=0; j<farm_num; j++) {
				scanf("%d", &tmp);
				if (j > i) {
					edges[edge_num].start = i;
					edges[edge_num].end = j;
					edges[edge_num].weight = tmp;
					edge_num++;
				}
			}
		}
		tmp = 0, result = 0;
		qsort(edges, edge_num, sizeof(edge_t), qsort_cmp);
		sets_init(farm_num);
		for (i=0; i<edge_num; i++) {
			if (sets_find(edges[i].start) != sets_find(edges[i].end)) {
				sets_union(edges[i].start, edges[i].end);
				tmp++;
				result += edges[i].weight;
			}
			if (tmp >= farm_num) {
				break;
			}
		}
		printf("%d\n", result);
	}
	
	return 0;
}

 

转载于:https://my.oschina.net/xiaoyunhu/blog/6018

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值