uva539 The Settlers of Catan

The Settlers of Catan

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:

When the game ends, the player who built the longest road gains two extra victory points.

The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).

Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.

Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o
Input
The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( $2 \le n \le 25$) and the number of edges m ( $1 \le m \le 25$). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output
For each test case, print the length of the longest road on a single line.
Sample Input
3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0
Sample Output
2
12

 

// 题意:输入n个结点和m条边的无向图(不一定连通),求最长路的长度。边不能经过两次,但是顶点可以重复经过
// 限制:2<=n<=25, 1<=m<=25,没有自环和重边
// 算法:DFS

 

dfs中更新深度d

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=26;
int a[maxn][maxn];
int n, m;
int ans;

void dfs(int i, int d)
{
    for(int j=0; j<n; j++) if(a[i][j]) {
        a[i][j]=0;
        a[j][i]=0;
        dfs(j, d+1);
        a[i][j]=1;
        a[j][i]=1;
    }
    ans=max(ans, d);
}

int solve()
{
    ans=0;
    for(int i=0;i<n;i++)
        dfs(i, 0);
    return ans;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("./uva539.in", "r", stdin);
#endif
    while(scanf("%d%d", &n, &m)==2 && (n || m)) {
        memset(a, 0, sizeof(a));
        for(int i=0;i<m;i++) {
            int x,y;
            scanf("%d%d", &x, &y);
            a[x][y]=1;
            a[y][x]=1;
        }
        printf("%d\n", solve());
    }

    return 0;
}

dfs求长度另一种写法: dfs返回最长长度

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=26;
int G[maxn][maxn];
int n, m;

int dfs(int i)
{
    int len=0;
    for(int j=0; j<n; j++) if(G[i][j]) {
        G[i][j]=G[j][i]=0;
        len=max(len, dfs(j)+1);
        G[i][j]=G[j][i]=1;
    }
    return len;
}

int solve()
{
    int ans=0;
    for(int i=0;i<n;i++)
        ans=max(ans, dfs(i));
    return ans;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("./uva539.in", "r", stdin);
#endif
    while(scanf("%d%d", &n, &m)==2 && (n || m)) {
        memset(G, 0, sizeof(G));
        for(int i=0;i<m;i++) {
            int x,y;
            scanf("%d%d", &x, &y); G[x][y]=G[y][x]=1;
        }
        printf("%d\n", solve());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值