HDU2058 The sum problem【数学计算+枚举】

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 26343    Accepted Submission(s): 7884
Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
Sample Input
 
  
20 10 50 30 0 0
Sample Output
 
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
Author
8600
Source

问题链接HDU2058 The sum problem

题意简述:参见上文。

问题分析

这个问题用数学方法+暴力法来解决,先做数学推导再编写枚举程序。

因为Sn=(a1+an)*n/2=a1*n+d(n-1)*n/2=a1*n+(n-1)*n/2(其中d=1),所以a1*n = m - (n-1)*n/2。

考虑最小的a1=1,则有Sn=n+(n-1)*n/2=(n+1)n/2。

那么n<=sqrt(2Sn)=sqrt(2m),即n最大值为sqrt(2m)。

基于以上推导,对n进行逐个试探即可。

程序说明:(略)

题记:(略)


AC的C语言程序如下:

/* HDU2058 The sum problem */

#include <stdio.h>
#include <math.h>

int main(void)
{
    int n, m, len, a1n, i;

    while(scanf("%d%d", &n, &m) != EOF && (n || m)) {
        len = (int)sqrt(m * 2.0);
        for(i=len; i>0; i--) {
            a1n = m - (i - 1) * i / 2;     //a1*n = m-(n+1)*n/2;
            if(a1n % i == 0)
                printf("[%d,%d]\n", a1n / i, a1n / i + i - 1);
        }
        putchar('\n');
    }

    return 0;
}



转载于:https://www.cnblogs.com/tigerisland/p/7563628.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值