A1038 Recover the Smallest Number (30 分)(拼接出最小数字)(贪心)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题意:

给出若干个可能有前导零的数字串,将他们按某个顺序拼接,使生成的数最小。

注意:

  1. 注意本题的一个误区:不可直接对数字按照从小到大的顺序排序,然后输出。比如32与321,正确顺序为 32132, 而不是32321
  2. 鉴于上述问题,采用这样一种贪心策略:对于数字串S1 与 S2,如果 S1+S2 < S2 + S1(加号表示拼接),那么把 S1放在 S2前面。
  3. 当结果串的所有前导零全部去掉,结果长度变为 0 时,应该输出 0.
  4. 本题中为了方便sort排序,采用string类型存储,注意本题中string类的使用。
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int maxn = 10010;
string str[maxn];
bool cmp(string a, string b){
  return a + b < b + a;   //string类字典序比较
} 
int main(){
  int n;
  cin >> n;
  for(int i = 0; i < n; i++){
    cin >> str[i];
  }
  sort(str, str + n, cmp);
  string ans;
  for(int i = 0; i < n; i++){
    ans += str[i];    //将排序后的数字串进行拼接
  }
  while(ans.size() != 0 && ans[0] == '0'){
    ans.erase(ans.begin());   //去除前导零
  }
  if(ans.size() == 0)
    cout << 0;
  else
    cout << ans;
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值