1102 Invert a Binary Tree(25 分)(C++)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

给定树的形状,求其中序遍历和层次遍历

#include <iostream>
#include <vector>
#include <cctype>
#include <queue>
using namespace std;
int tree[15][2],n,root,cnt = 0;
bool visit[10];
std::vector<int> level(n),inorder(n);
void intravel(int index){
    if(index == -1)
        return;
    intravel(tree[index][0]);
    if(cnt != 0)
        printf(" ");
    else
    	printf("\n");
    printf("%d",index);
    cnt++;
    intravel(tree[index][1]);
}
void leveltravel(int index){
    printf("%d",index);
    queue<int>q;
    q.push(index);
    while(!q.empty()){
        int temp = q.front();
        q.pop();
        if(tree[temp][0] != -1){
            printf(" %d",tree[temp][0]);
            q.push(tree[temp][0]);
        }
        if(tree[temp][1] != -1){
            printf(" %d",tree[temp][1]);
            q.push(tree[temp][1]);
        }
    }
}
int main(){
    scanf("%d",&n);
    fill(tree[0],tree[0]+15*2,-1);
    for(int i = 0; i < n; i++){
        char left,right;
        getchar();
        scanf("%c %c",&right,&left);
        if(isdigit(right)){
            visit[right - '0'] = true;
            tree[i][1] = right - '0';
        }
        if(isdigit(left)){
            visit[left - '0'] = true;
            tree[i][0] = left -'0';
        }
    }
    for(int i = 0; i < n; i++)
        if(visit[i] == false){
            root = i;
            break;
        }
    leveltravel(root);
    intravel(root);
}

优化一下,将层次遍历与中序遍历结合在一起

#include <iostream>
#include <vector>
using namespace std;
bool visit[15];
int n, tree[15][2], root = 0;
vector<int>levelcnt[15],in;
void intravel(int index, int level){
	if(index == -1)
		return;
	levelcnt[level].push_back(index);
	intravel(tree[index][1], level + 1);
	in.push_back(index);
	intravel(tree[index][0], level + 1);
}
int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; ++ i){
		char a, b;
		getchar();
		scanf("%c %c", &a, &b);
		if(a != '-'){
			tree[i][0] = a - '0';
			visit[a - '0'] = true;
		}
		else
			tree[i][0] = -1;
		if(b != '-'){
			tree[i][1] = b - '0';
			visit[b - '0'] = true;
		}
		else
			tree[i][1] = -1;
	}
	while(visit[root]) ++ root;
	intravel(root, 0);
	printf("%d", levelcnt[0][0]);
	for(int i = 1; levelcnt[i].size() != 0; ++ i)
		for(int j = 0; j < levelcnt[i].size(); ++ j)
			printf(" %d", levelcnt[i][j]);
	printf("\n");		
	printf("%d",in[0]);
	for(int i = 1; i < n; ++ i)
		printf(" %d", in[i]);
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值