POJ 1013 Counterfeit Dollar

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 46493 Accepted: 14712

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings. 

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even. 

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined. 

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 
//题目的要求是找出用A-L代表硬币中的假币,通过天平称量,每一个事件输入三组数组,每一组数据包括左边天平放置的硬币并用字母显示,右边天平放置的用字母显示的硬币,最后是右边天平的显示,up,down,even.找出假币对应的字母。
//因为只有一个是假币,所以凡是even 结果的肯定都是真币,可以统计显示出even结果的字母,并对其进行标记,也就是真币标记。最后循环12次找出于其他标记不相等的即为假币。在统计显示up,down 结果的字母是,因为无法确定假币是在左侧还是在右侧,需要同时对两侧的字母进行标记,可以是左侧的增加,右侧的减小
#include<iostream>
#include<string>
using namespace std;
int main()
{
    int n;
    cin >> n;
    while (n--)
    {
        int a[12] = { 0 };
        int bad = 0;//记录有几次天平不平衡
        for (int i = 0; i < 3; i++)
        {
            string s1, s2, c;
            cin >> s1 >> s2 >> c;
            if (c == "up")
            {
                for (int j = 0; j < s1.size(); j++)
                    a[s1[j] - 65] ++;//左边重的都+1
                for (int j = 0; j < s2.size(); j++)
                    a[s2[j] - 65] --;//右边轻的都-1
                bad++;//不平衡次数+1
            }
            else if (c == "down")
            {
                for (int j = 0; j < s1.size(); j++)
                    a[s1[j] - 65] --;
                for (int j = 0; j < s2.size(); j++)
                    a[s2[j] - 65] ++;
                bad++;
            }
            else if (c == "even")
                for (int j = 0; j < s1.size(); j++)
                    a[s1[j] - 65] = a[s2[j] - 65] = 4;
            //不一定非要是9  其实只要是一个比3大的数就行 因为最多有3次不平衡
        }
        for (int i = 0; i < 12; i++)
        {
            if (a[i] == bad) //如果有一个 有bad次++
                cout << char(i + 65) << " is the counterfeit coin and it is heavy." << endl;
            if (a[i] == -bad)//如果有一个 有bad次--
                cout << char(i + 65) << " is the counterfeit coin and it is light." << endl;
        }
    }	
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值