HDU 1076 JAVA

An Easy Task

Problem Description

Lgnatius was born in a leap year, so he want to know when he could hold
his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

Output

For each test case, you should output the Nth leap year from year Y.

Sample Input

3
2005 25
1855 12
2004 10000

Sample Output

2108
1904
43236

题意: 给你两个数Y、N ,要求你输出Y年之后的第N个闰年的年份,要是Y是闰年,那么Y算第一个闰年。

JAVA实现代码

package hlh;

import java.util.Scanner;
/**
 * @author<a href="mailto:953801304@qq.com">胡龙华</a>
 * @version 2017-5-18  下午5:11:30
 * @fileName p1076.java
 */
public class p1076 {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int y = sc.nextInt();
            int n = sc.nextInt();
            //这一年是闰年,i就从1开始  不是就从0开始
            int i = leapYear(y)?1:0;
            // 每过4年判断一下,
            while(true){
                if(i==n){
                    break;
                }
                y++;
                // i 统计过了的闰年数, 每到一个闰年 就+1
                if(leapYear(y)){
                    i++;
                }
            }
            System.out.println(y);
        }
    }

    private static boolean leapYear(int i) {

        boolean boo=false;
        if(i%4==0 && i%100!=0){
            boo=true;
        }else if( i%400==0){
            boo=true;
        }

        return boo;
    }

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值