1002 A+B for Polynomials (25分)

PAT (Advanced Level) Practice

题目链接.

  • 编程题 1002 A+B for Polynomials (25分)
    参考自《算法笔记》

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ aN​1​​ ​​ N​2​​ a​N​2​​ ​​ … N​K​​ a​N​K
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

/*********************************************************************************************************************************/

参考代码

#include <cstdio>
const int max_n = 1111;
double p[max_n] = {};	//p 数组需定义为 double 型,初值为 0,p[n] 表示幂次为 n 的项的系数
int main() {
    int k, n, count = 0;	//k 表示每个多项式系数非零项的项数,n 表示指数
    double a;	//a 表示系数
    scanf ("%d", &k);
    for (int i = 0; i < k; i++) {
        scanf ("%d %lf", &n, &a);
        p[n] += a;	//这一步是重点
    }
    scanf ("%d", &k);
    for (int i = 0; i < k; i++) {
        scanf ("%d %lf", &n, &a);
        p[n] += a;	//相同的指数,则系数相加
    }
    for (int i = 0; i < max_n; i++) {	//这一步判断,多项式系数非零项的项数。需考虑到两个多项式相加系数正负抵销的情况
        if (p[i] != 0)  count++;
    }
    printf ("%d", count);
    for (int i = max_n - 1; i >= 0; i--) {	//注意幂次为 1000 是可以取得到的,所以循环的最大值至少要取 1000(所以 p 数组的大小至少是 10001)。输出要按照幂次从大到小的顺序,系数格式上要保留一位小数
        if (p[i] != 0)  printf (" %d %.1f", i, p[i]);	//输出时的空格需注意,不然会有格式错误
    }

    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值