ALDS1_4_C:Dictoinary采用map

题目链接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=ALDS1_4_C

题目如下:

Search - Dictionary

Time Limit : 2 sec, Memory Limit : 131072 KB

Search III

Your task is to write a program of a simple dictionary which implements the following instructions:

insert str: insert a string str in to the dictionary
find str: if the distionary contains str, then print ‘yes’, otherwise print ‘no’
Input

In the first line n, the number of instructions is given. In the following n lines, n instructions are given in the above mentioned format.

Output

Print yes or no for each find instruction in a line.

Constraints

A string consists of ‘A’, ‘C’, ‘G’, or ‘T’
1 ≤ length of a string ≤ 12
n ≤ 1000000

Sample Input 1
5
insert A
insert T
insert C
find G
find A
Sample Output 1
no
yes

Sample Input 2
13
insert AAA
insert AAC
insert AGA
insert AGG
insert TTT
find AAA
find CCC
find CCC
insert CCC
find CCC
insert T
find TTT
find T

Sample Output 2
yes
no
no
yes
yes
yes

代码如下:

#include <iostream>
#include <map>
#include <algorithm>
#include <cstring>
using namespace std;
int main(){
  ios::sync_with_stdio(false);
  map<string,int> mp;
  int n;
  cin>>n;
  char ord[20],str[20];
  for(int i=0;i<n;i++){
    cin>>ord;
    if(ord[0]=='i'){
      cin>>str;
      mp.insert(make_pair(str,1));
    }
    else{
      cin>>str;
      if(mp.count(str))    cout<<"yes"<<endl;
      else     cout<<"no"<<endl;
    }
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

一倾而尽

你的鼓励将是我最大的动力,谢谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值