1146 Topological Order (25 分)(拓扑排序)

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目大意:

给定一个有向图,然后判断给定的若干序列是不是拓扑排序

思路:

1、建立图。建立入度数组,给定的序列先判断入度是否为0,若是0,则邻接点入度减1,不是0,break;循环以上

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
import java.util.ArrayList;

public class Main {

	static int N, M, K;
	static int[][] G;

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		in.nextToken();
		N = (int) in.nval;
		in.nextToken();
		M = (int) in.nval;
		G = new int[N + 1][N + 1];
		for (int i = 0; i < M; i++) {
			in.nextToken();
			int x = (int) in.nval;
			in.nextToken();
			int y = (int) in.nval;
			G[x][y] = 1;
		}

		int[] indegree = new int[N + 1];

		for (int i = 1; i < N + 1; i++) {
			int rudu = 0;
			for (int j = 1; j < N + 1; j++) {
				if (G[j][i] != 0)
					rudu++;
			}
			indegree[i] = rudu;
		}

		in.nextToken();
		K = (int) in.nval;

		ArrayList<Integer> list = new ArrayList<>();

		for (int i = 0; i < K; i++) {
			int[] al = new int[N + 1];
			for (int p = 1; p < N + 1; p++) {
				al[p] = indegree[p];
			}
			
			int arr [] = new int[N];
			for(int k=0;k<N;k++) {
				in.nextToken();
				int num = (int) in.nval;
				arr[k] = num;
				
			}
			
			for (int k = 0; k < N; k++) {
				int num = arr[k];
				if (al[num] != 0) {
					list.add(i);
					break;
				} else {
					for (int j = 1; j < N + 1; j++) {
						if (G[num][j] != 0) {
							al[j]--;
						}
					}
				}

			}
		}

		int flag = 0;
		for (Integer tmp : list) {
			if (flag == 0) {
				System.out.print(tmp);
				flag = 1;
			} else
				System.out.print(" " + tmp);
		}

	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值