HDU - 5916 - Harmonic Value Description (思维 & 构造)

题目链接
The harmonic value of the permutation p1,p2,⋯pnp1,p2,⋯pn is
n-1
∑ gcd(pi.pi+1)
i= 1

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
Input
The first line contains only one integer T (1≤T≤1001≤T≤100), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k (1≤2k≤n≤100001≤2k≤n≤10000).
Output
For each test case, output one line “Case #x: p1 p2 ⋯ pnp1 p2 ⋯ pn”, where x is the case number (starting from 1) and p1 p2 ⋯ pnp1 p2 ⋯ pn is the answer.
Sample Input
2
4 1
4 2
Sample Output
Case #1: 4 1 3 2
Case #2: 2 4 1 3

刚开始没看懂什么意思,其实就是找一个1到n的排列,使得相邻连个数的最大公约数和达到第k大。emmm,这里面想一下的话,最小就是1到n顺序排列的情况,是n-1,所以,我们就把第k个数和第2k个数拿到一起,并且让剩下的相邻最大公约数都是1就好了。那么这个时候,需要判断一下第三个数和第2个数是不是互质,如果不互质的话,那么就把第3个数和2k-1换一下,因为,2k是偶数,又与3不互质,说明是6的倍数,那么2k-1一定与3互质。参考题解点这里
AC代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1e4 + 5;
int a[maxn];

int main()
{
    int t, n, k;
    scanf("%d", &t);
    for(int test = 1; test <= t; test ++)
    {
        scanf("%d%d", &n, &k);
        for(int i = 1; i <= n; i++) a[i] = i;
        swap(a[1], a[k]);
        swap(a[2], a[2 * k]);
        if(a[2] % 3 == 0)   swap(a[3], a[2 * k - 1]);

        printf("Case #%d:", test);
        for(int i = 1; i <= n; i++) printf(" %d", a[i]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值