String Problem HDU - 3374 (KMP+最小表示法)

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings: 
String Rank 
SKYLONG 1 
KYLONGS 2 
YLONGSK 3 
LONGSKY 4 
ONGSKYL 5 
NGSKYLO 6 
GSKYLON 7 
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once. 
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also. 

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab

Sample Output

1 1 6 1
1 6 1 6
1 3 2 3

题目大意:对于每个字符串输出以哪个开始的字符串字典序是最小的,再输出有几个循环节,再输出字典序最大的,在输出有几个循环节。

解题思路:用KMP找出最小循环节,对于字典序用最小表示法即可。

/*
@Author: Top_Spirit
@Language: C++
*/
#include <bits/stdc++.h>
using namespace std ;
typedef unsigned long long ull ;
typedef long long ll ;
const int Maxn = 1e6 + 10;
const int INF = 0x3f3f3f3f ;
const ull seed = 133 ;
const int MOD = 10007 ;
const double PI = acos(-1.0) ;
const int Max = 200 + 10 ;

string s ;
int len ;
int Next[Maxn] ;

void getNext(){
    Next[0] = -1 ;
    int j = 0, k = -1 ;
    while (j < len){
        if (k == -1 || s[j] == s[k]) Next[++j] = ++k ;
        else  k = Next[k] ;
    }
}

int Min_or_Max(int flag){
    int i = 0, j = 1, k = 0 ;
    while (i < len && j < len && k < len){
        int tmp = s[(i + k) % len] - s[(j + k) % len] ;
        if (!tmp) k++ ;
        else if (!flag){
            if (tmp < 0) i += k + 1;
            else j += k + 1 ;
            if (i == j) j++ ;
            k = 0 ;
        }
        else if (flag){
            if (tmp > 0) i += k + 1 ;
            else j += k + 1 ;
            if (i == j) j++ ;
            k = 0;
        }
    }
    return min(i, j) ;
}

int main (){
    ios_base::sync_with_stdio(false) ;
    cin.tie(0) ;
    cout.tie(0) ;
    while (cin >> s){
        memset(Next, 0, sizeof(Next)) ;
        len = s.size() ;
        getNext() ;
        int Max = Min_or_Max(0) ;
        int Min = Min_or_Max(1) ;
        int cnt = len - Next[len] ;
        int ans = len % cnt == 0 ? len / cnt : 1;
        cout << Min + 1 << " " << ans << " " << Max + 1 << " " << ans << endl ;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值