String Problem HDU - 3374(字符串的最大最小表示)

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
Sample Input
abcder
aaaaaa
ababab
Sample Output
1 1 6 1
1 6 1 6
1 3 2 3
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N = 1000005;
char str[N];
int Next[N];
void getNext(char p[],int m,int Next[]){
	int i=0;
	int t=-1;
	Next[0]=-1;
	while(i<m){
		if(t<0||p[i]==p[t])
		   Next[++i]=++t;
	    else t=Next[t];
	}
}
int min_max_expree(char str[],int len,int flag){
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len){
		int t=str[(j+k)%len]-str[(i+k)%len];
		if(t==0) k++;
		else{
			if(flag){
				if(t>0) j+=k+1;
				else i+=k+1;
			}
			else{
				if(t>0) i+=k+1;
				else j+=k+1;
			}
			if(i==j) j++;
			k=0;
		}
	}
	return min(i,j);
}
int main(){
	while(scanf("%s",str)!=EOF){
		int len=strlen(str);
		int min_express=min_max_expree(str,len,1);
		int max_express=min_max_expree(str,len,0);
		getNext(str,len,Next);
		int l=len-Next[len];
		int ans=len%l?1:len/l;
		printf("%d %d %d %d\n",min_express+1,ans,max_express+1,ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值