PAT1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n​3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that
n 1 = n 3 = m a x n1=n3=max n1=n3=max { k ∣ k ≤ n 2 k| k≤n2 kkn2 for all 3 ≤ n 2 ≤ N 3≤n2≤N 3n2N } with n 1 + n 2 + n 3 − 2 = N n1+n2+n3−2=N n1+n2+n32=N.


Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.


Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor




解析

这题本以为可以发现字符排列的规律的。但是没有。
这个条件我找不到n1,n2,n3的等式。
n 1 = n 3 = m a x n1=n3=max n1=n3=max { k ∣ k ≤ n 2 k| k≤n2 kkn2 for all 3 ≤ n 2 ≤ N 3≤n2≤N 3n2N } with n 1 + n 2 + n 3 − 2 = N n1+n2+n3−2=N n1+n2+n32=N.
没办法:只能使用暴力迭代了
因为n1 = n2,所以可以得到n1和n2的表达式为 2 ∗ n 1 + n 2 − 2 = N 2*n1+n2-2=N 2n1+n22=N。根据n2的值.
因为n2在 3 ≤ n 2 ≤ N 3≤n2≤N 3n2N。所以迭代n2的值。根据上面推的式子,可以的到n1的值。其中:每步迭代中,n1最大的值且n1<=n2。那么这就是n1,n2,n3的值,具体代码如下:

	char input[100];
	scanf("%s", input);
	int Len = strlen(input);
	int n1, n2;
	for (n2 = 3; n2 <= Len; n2++) {
		n1 = (Len + 2 - n2)/2;
		if (n1 + n1 + n2 - 2 == Len && n1 <= n2)
			break;
	}

知道n1,n2,n3的值后,我把字符串填充到二维数组里。最后输出二维数组。



#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;
int main()
{
	char input[100];
	scanf("%s", input);
	int Len = strlen(input);
	int n1, n2;
	for (n2 = 3; n2 <= Len; n2++) {
		n1 = (Len + 2 - n2)/2;
		if (n1 + n1 + n2 - 2 == Len && n1 <= n2)
			break;
	}
	vector<vector<char>> array(n1,vector<char>(n2,' '));
	int index = 0;     // for string
	for (int i = 0; i < n1; i++) 
		array[i][0] = input[index++];
	for (int i = 1; i < n2 - 1; i++)
		array[n1 - 1][i] = input[index++];
	for (int i = n1 - 1; i >= 0; i--)
		array[i][n2 - 1] = input[index++];
	for (auto v : array) {
		for (auto i : v)
			printf("%c", i);
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值