PAT-A 1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路:

首先应该明确,两个垂直方向上的字符的数量应该相等,按照这个准则,如果输入字符串的长度为偶数,底部的字符数量应该为偶数,否则底部的字符串应该为奇数。由于字符串长度最少是5,那么底部字符的数量为奇数时最少是3(对应输入字符串长为5),底部字符的数量为偶数时最少是4(对应输入字符串长为6)。

然后,根据输入字符串长度的奇偶将底部字符的数量初始化为3或4,这时可以得到一个U,但不一定符合题目要求,进行调整。调整的策略是:每次将底部字符串数量加2,同时将两边的高度减1,直到符合题干要求。

得到了底部字符的数量后,从上到下打印"U"即可。

#include <iostream>
#include <string>

using namespace std;

int main()
{
    string in;

    cin >> in;

    int N = in.size();
    int bottom = (N % 2) ? 3 : 4;//初始化底部的字符,保证两边高度相同
    int k = (N - bottom) / 2;
    while(k + 1 > bottom)
    {
        bottom += 2;
        k--;
    }

    int i;
    for(i = 0; i < k; i++)
    {
        printf("%c", in[i]);//打印"U"的左边字符
        for(int j = 0; j < bottom - 2; j ++)
            printf(" ");//打印左边字符和右边字符之间的空格
        printf("%c\n", in[N - i - 1]);//打印"U"的右边字符
    }
    for(int j = 0; j < bottom; j++)
        printf("%c", in[i++]);//打印底部字符
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值