HDU - 2586 How far away ? LCA离线

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases. 
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n. 
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

模板题  参照了一位博主的做法

第一次lca

此做法不需路径压缩  每个节点的祖先都是它的上一层 因为如果用了路径压缩会破坏层次关系 因为所有的节点的祖先都会指向1

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
#define clr(a,b) memset(a,b,sizeof(a));
using namespace std;
const int maxn=40005;
int path[maxn];
struct node
{
	int oth,dis;
};
vector<node> map[maxn];
vector<node> query[maxn];
int ans[maxn];
int f[maxn];
bool flag[maxn];

int find(int x)
{
	while(x!=f[x])
	{
		x=f[x];
	}
	return x;
}

int LCA(int k)
{
	int oth1,oth2;
	for(int i=0;i<map[k].size();i++)
	{
		oth1=map[k][i].oth;
		if(!flag[oth1])
		{
			flag[oth1]=true;
			path[oth1]=path[k]+map[k][i].dis;
			LCA(oth1);
			f[oth1]=k; 
			for(int j=0;j<query[oth1].size();j++)//遍历到最后一个节点 - 一层才会开始查询 (最后一个点没有出边 进不了循环 直接return0) 
			{
				oth2=query[oth1][j].oth;//虽是以k为始点进行操作 但是k的出边oth1已经return0 说明k的子节点已经没有子节点了 所以以oth1作为出边来查询 
				if(flag[oth2]&&ans[query[oth1][j].dis]==0)
				{
					if(oth1!=oth2)
					{
						 ans[query[oth1][j].dis]=path[oth1]+path[oth2]-2*path[find(oth2)];//在同一侧子树中find是无用的 但是不同侧子树find就有它的作用 
					}
				}
			}
		}
	}
	return 0;
}

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		clr(path,0)
		clr(ans,0)
		clr(flag,0)
		for(int i=1;i<=n;i++)
		{
			query[i].clear();
			map[i].clear();
			f[i]=i;
		}
		node temp;
		for(int i=1;i<n;i++)//简单路径 
		{
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			temp.dis=w;
			temp.oth=v;
			map[u].push_back(temp);
			temp.oth=u;
			map[v].push_back(temp);
		}
		for(int i=1;i<=m;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			temp.oth=b;
			temp.dis=i;
			query[a].push_back(temp);
			temp.oth=a;
			query[b].push_back(temp);
		} 
		flag[1]=1;
		path[1]=0;
        LCA(1);	
		for(int i=1;i<=m;i++)
        {
        	printf("%d\n",ans[i]);
        }	
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值