HDU1083-Courses(最大匹配问题+匈牙利算法)

题目链接

Problem Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:
. every student in the committee represents a different course (a student can represent a course if he/she visits that course)
. each course has a representative in the committee
Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.
An example of program input and output:

Sample Input

2

3 3

3 1 2 3

2 1 2

1 1

3 3

2 1 3

2 1 3

1 1

Sample Output

YES

NO


题目大意

课程个数p,学生个数n,一门课程由若干学生选择。每门课程选择一个课代表,一个学生只能担任一门课的课代表,问是否可以

思路

把课程和学生作为二分图处理,课程作为左图,学生作为右图,求不带权的最大匹配问题。用匈牙利算法

匈牙利算法

匈牙利算法主要的三种用途

匈牙利算法讲解

增广路的理解  打拳皇98的例子很具体形象

最核心的就是寻找增广路,用递归实现。

vis标记数组,标记右图的点,用来递归找增广路时候不再对标记过的点访问,注意每次遍历一个左边的点都要清空vis数组。

link数组,link[R] = L,表示右边的点和左边的点的匹配,-1表示R点没有匹配。

测试用例建二分图的情况:


#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f

using namespace std;

int ln,rn;
int a[110][310],vis[310],link[310];

int dfs(int L)
{
    for(int R=1;R<=rn;R++){
        if(a[L][R]&&!vis[R]){
            vis[R] = 1;
            if(link[R]==-1||dfs(link[R])){
                link[R] = L;
                return 1;
            }
        }
    }
    return 0;
}

int hungary()
{
    int ans = 0;
    memset(link,-1,sizeof(link));
    for(int i=1;i<=ln;i++){
        memset(vis,0,sizeof(vis));
        if(dfs(i)) ans++;
    }
    return ans;
}

int main()
{
    int T; scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&ln,&rn);
        memset(a,0,sizeof(a));
        for(int i=1;i<=ln;i++){
            int t,x;
            scanf("%d",&t);
            for(int j=1;j<=t;j++){
                scanf("%d",&x);
                a[i][x] = 1;
            }
        }
        if(hungary()==ln) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值