POJ2299-Ultra-QuickSort(树状数组 离散化)

题目链接

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence

9 1 0 5 4 ,

Ultra-QuickSort produces the output

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5

9

1

0

5

4

3

1

2

3

0

Sample Output

6

0


题意

对一行数进行排序,方法是交换相邻两个数,问需要交换多少次,可以排成升序。

思路

对于5 4 3 2 1而言,交换的次数是0+1+2+3+4=10,每次加上前面大于该位的个数,5的前面没有比5大的,4的前面有一个比4大的(5),3的前面有2个比3大的(5和4)。每次加入一个数,然后计算比他大的个数。

用树状数组维护等于n的有多少个数。 每次先增加一个数的时候,计算前面增加的数有多少个比他大,则答案增加这个个数。

sum(x)是小于等于x的个数,i是当前所有数量,i - sum(x)就是大于x 的个数。

最大9 9999 9999,太大无法建立数组,但是实际只有50 0000个数,可以将其离散化,比如1,100,3,80,2;可以离散化为1,5,3,4,2。

ans用long long 保存,可能会超int。

树状数组模板

代码参考


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 500010;
int c[maxn],tt[maxn];
int n;
ll ans;

struct node
{
    int x,id;
}a[maxn];

bool cmp(node a,node b)
{
    return a.x<b.x;
}

int lowbit(int x)
{
    return x & -x;
}

int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res += c[x];
        x -= lowbit(x);
    }
    return res;
}

void update(int x)
{
    while (x<=n)
    {
        c[x]++;
        x += lowbit(x);
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        ans = 0;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i].x);
            a[i].id = i;
        }
        sort(a+1,a+n+1,cmp);
        for(int i=1;i<=n;i++) tt[a[i].id] = i;
        for(int i=1;i<=n;i++){
            update(tt[i]);
            ans += i-sum(tt[i]);
        }
        printf("%lld\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值