Arbitrage——floyd算法

http://acm.hdu.edu.cn/showproblem.php?pid=1217

Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0

Sample Output

Case 1: Yes

Case 2: No

思路

用map存储标记字符串编号,觉得map真好用!!!

即是字符串a不在mp里也可以直接赋值使用,以下两种写法都可以:

mp[a]=i;
mp.insert(pair<string,int>(a,i)); 

这道题的关键是想明白初始化要设置成0,因为以往的最短路问题都是设置成INF或者是-1,所以这也是这道题我想了好久的点。

 

代码

#include<bits/stdc++.h>
using namespace std;

map<string,int> mp;
double m[35][35];
double dis[35][35];

int main(){
	int n,c,cnt=0;
	double d;
	string a,b;
	while(cin>>n){
		cnt++;
		if(n==0) break;
		memset(m,0,sizeof(m));//初始化必须等于0 
		for(int i=0;i<n;i++){
			cin>>a;
//			mp[a]=i;
			mp.insert(pair<string,int>(a,i)); 
		}
		cin>>c;
		for(int i=0;i<c;i++){
			cin>>a>>d>>b;
			m[mp[a]][mp[b]]=d;
		}
		for(int k=0;k<n;k++){
			for(int i=0;i<n;i++){
				for(int j=0;j<n;j++){
					m[i][j]=max(m[i][j],m[i][k]*m[k][j]);
				}
			}
		}
		
		int flag=0;
		for(int i=0;i<n;i++){
			if(m[i][i]>1){
				cout << "Case "<< cnt << ": Yes" <<endl;
				flag=1;
				break;
			} 
		}
		if(!flag) cout << "Case "<< cnt << ": No" <<endl;
	}	
	
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值